www.yzc261.comphpsdk下七牛官方单元测试代码执行类依赖错误

( www.yzc261.com )

执行自带单元测试时,依赖报错
执行过程如下:

//test目录
AuthTest.php  Base64Test.php  BucketTest.php  Crc32Test.php  DownloadTest.php  EtagTest.php  FopTest.php  FormUpTest.php  HttpTest.php    PfopTest.php  ResumeUpTest.php
//执行
phpunit PfopTest

类没找到,应该是安装没有安装对


支持以下几种安装方式。推荐使用 Composer安装方式 。


使用 Composer 安装

Composer 是一个简单易用的 PHP 依赖管理工具。你可以在自己的项目中声明所依赖的外部工具库,Composer 会自动帮你安装这些依赖的库文件。

使用 Composer 安装 Qiniu SDK 的步骤非常简单:

安装 Composer :
curl -sS https://getcomposer.org/installer | php
使用 Composer 获取最新版本的 Qiniu SDK :
php composer.phar require qiniu/php-sdk
你代码中 require Composer生成的 autoloader:
<?php
require 'vendor/autoload.php';
如果需要更详细的关于 Composer 的使用说明,你可以访问 Composer 的官方网站http://getcomposer.org/,或对应的中文网站 http://www.phpcomposer.com/。


直接下载 Composer 安装包

鉴于某些原因, 国内的用户使用 Composer 下载依赖库比较慢,开发者也可以直接下载我们准备好的符合 Composer 规范的 vendor 压缩包并在本地解压。解压后的内容和使用 Composer 方式获取到的内容完全一致,之后的使用方式也一致。

压缩包下载地址:http://devtools.qiniu.io/vendor.tar.gz


下载源代码包

直接下载源代码压缩包并解压是另一种 SDK 的安装方法。不过因为有版本更新的维护问题,这种安装方法并不推荐,仅作为万一 Composer 安装有问题的情况下作为一种选择。 并且,源码中也包含 Qiniu SDK 的 autoloader。

下载源代码包后,解压到您的项目中。 然后在您的项目中引入 autoloader:

  <?php
  require 'path_to_sdk/autoload.php';
即可以使用七牛相关功能。

注意安装后还要引入:

无论你是通过哪种方式安装SDK, 安装之后必须将SDK包含到你的项目中才可以调用SDK中的方法。你可以参考以下的表格,按照你的安装方式将SDK引入到你的项目中。只需要一句简单的 require 将autoloader引入即可使用,注意要将 path_to_sdk 替换成你项目中的实际路径。

安装方式    引入SDK
Composer 安装    require 'path_to_sdk/vendor/autoload.php';
下载Composer安装包    require 'path_to_sdk/vendor/autoload.php';
下载源码安装包    require 'path_to_sdk/autoload.php';

(看完/读完)这篇文章有何感想! www.yzc261.com的分享…

发表评论

电子邮件地址不会被公开。 必填项已用*标注